Page 1 of 1

What's wrong with my amp setup

PostPosted: Thu Jan 04, 2018 10:38 am
by lovechet
My setup sounded super 6 months ago but after sitting unused for that length of time now it sounds terrible. The only thing that happened is that when I starting using it recently all it did is hum loudly. Luckily I looked in the back and saw a bolt shorting from the spkr magnet over to the spkr metal shroud. Removing it fixed the loud hum. I assume I didn't pooch anything. The spkr measures 6.5 ohms. The Amp works now but sounds terrible. Hoping its just tubes.

I have a Fender Deluxe with an FX loop that was added into channel 2 (reverb channel) by Paul Rivera. The FX loop uses an added 12AX7. I use a Stryman reverb in the FX loop. I don't use the onboard spring reverb at all, just set to zero. I also use a Weber Mass. The FX loop works but I can't turn up the send and receive hardly at all or it hums. Also the preamp Bass and Treble controls seem unresponsive or at best sloppy. Totally lacking in lows. Weber Mass also seems unresponsive. I am assuming its my 6V6 power tubes that need replacing or possibly those sockets have gone bad again. When I turn on the standby switch one of the 6V6 gets just a little purple glow and then mostly goes away. Not sure if that's normal. I can also play with the channel 2 preamp (v2) phase inverter (V6), or the fx loop 12AX7.

Any thoughts ?

PS: A am playing a Country Gentleman through it.

Re: What's wrong with my amp setup

PostPosted: Mon Jan 22, 2018 3:46 pm
by lovechet
After using for awhile everything seemed to have straighten out. Must have been the electrolytic caps adjusting.

Then replaced V2 (channel 2 preamp stage) 12AX7EH Russian made with a 12AX7 JJ Electronic and that made a huge difference. Everything smoothed out. I'm not saying either tube type is better, It's just that in this case is made a huge difference. The old tube made have been marginal.

The conclusion, don't let your equipment sit unused, and also don't be afraid to change out tubes to see what difference it makes. It's a never ending battle.

Re: What's wrong with my amp setup

PostPosted: Fri Feb 16, 2018 10:01 am
by Wanner
Glad to see you sorted this out, Lovechet. These kind of problems are my worst nightmare. They mess with your head. At least that's how it is with me.